link Telstra Cable Cisco Router Base Config← Back

For my new Telstra cable Internet connection I was supplied with a Netgear CG3100D-2 modem/router and I wanted to use it with my existing Cisco 2821 router. The following steps and basic Cisco config will allow you to establish a working Internet connection.

The same config should be compatible with 2921, 2941, 1921 and 1941 routers. For 1821 and 1841 routers you'll need to substitute gi0/0 and gi0/1 with fe0/0 and fe0/1 as those models only had 100mbps network interfaces.

Once you have the basic connection up and running you'll also most likely want to apply your own port forwarding rules and access group to the external interface. N.B. When applying an access group to the external interface you'll need to accept UDP responses from port 67 to allow the DHCP response to be accepted from Telstra.

With my customised NAT and firewall rules applied I still achieved 36mbps/1mbps speed test results on Telstra's speed test which was the same as when tested directly through the Netgear.

I am assuming you have already know how and have configured gi0/1 on the Cisco with an appropriate private IP so that you can telnet to it from your PC. My base config will require customisation for your environment in terms of subnets and internal DHCP.

  1. Login to the Netgear web GUI
  2. Open Wireless Settings from the left menu and untick Allow Broadcast of Name and Enable Wireless Access Point then click Apply
  3. Open Wi-fi Multimedia from the left menu and set all dropdown boxes to Off then click Apply
  4. Open NAT Mode from the left menu and select NAT - Disable (Bridge Mode) then click Apply. The router will reboot.
  5. Connect the Ethernet 1 port of the Netgear to gi0/0 on your Cisco.
  6. Connect your PC to gi0/1 on the Cisco and login.
  7. Apply the base config. You'll need to customise the passwords and internal IP/DHCP subnets to match your environment. Also note that I've used Qld name servers so if you're in a different state you'll need to substitute those IPs with your local DNS IPs.
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service internal
    service sequence-numbers
    !
    hostname router
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret yourpass
    !
    no aaa new-model
    clock timezone AEST 10
    !
    resource policy
    !
    no ip subnet-zero
    no ip source-route
    ip tcp selective-ack
    ip tcp timestamp
    !
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.0.1 192.168.0.50
    ip dhcp excluded-address 192.168.0.200 192.168.0.254
    !
    ip dhcp pool dhcppool
       network 192.168.0.0 255.255.255.0
       default-router 192.168.0.254
       domain-name yourdomain.local
       dns-server 61.9.211.1 61.9.211.33
       update arp
    !
    ip name-server 61.9.211.1 61.9.211.33
    !
    interface GigabitEthernet0/0
     ip address dhcp
     ip nat outside
     duplex auto
     speed auto
     no cdp enable
    !
    interface GigabitEthernet0/1
     ip address 192.168.0.254 255.255.255.0
     ip nat inside
     duplex auto
     speed auto
    !
    ip classless
    no ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 1 interface GigabitEthernet0/0 overload
    !
    access-list 1 remark NAT
    access-list 1 permit 192.168.0.0 0.0.0.255
    access-list 2 remark Telnet management
    access-list 2 permit 192.168.0.0 0.0.0.255
    !
    control-plane
    !
    line con 0
     transport output all
    line aux 0
     transport output all
    line vty 0 4
     access-class 2 in
     password yourpass
     login
     transport input all
     transport output all
    !
    scheduler max-task-time 5000
    scheduler allocate 20000 1000
    sntp server au.pool.ntp.org
    
  8. Connect the Gi0/1 interface to your switch and also connect your PC to the switch and you should have Internet access.
  9. You should also be able to access the Netgear web GUI to adjust some basic settings.

Comments

There are no comments


Post a comment